Autore Topic: Segmento non corretto nel profilo  (Letto 707 volte)

AndreaMara

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Segmento non corretto nel profilo
« il: Febbraio 02, 2022, 04:06:56 pm »
Ciao,

sto imparando ora e ho poca esperienza.....non capisco se è un errore mio (o qualche impostazione inserita per sbaglio) o un piccolo bug.

Nel file allegato i caposaldi 169-170-171 sono corretti nel calcolo dei dati e sono ok nel disegno in pianta, mentre nella visualizzazione del profilo risulta un segmento 170-170 che non riesco a capire e che non è corretto.
Un aiuto sarebbe molto gradito.

grazie
Andrea

cepe

  • Administrator
  • Hero Member
  • *****
  • Post: 549
    • Mostra profilo
Re:Segmento non corretto nel profilo
« Risposta #1 il: Febbraio 03, 2022, 09:32:06 am »
Io la poligonale la vedo come in allegato...
Manda  uno screenshot di come invece la vedi tu e dove sta questo tiro 'alieno'.

AndreaMara

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re:Segmento non corretto nel profilo
« Risposta #2 il: Febbraio 03, 2022, 10:37:13 am »
Ciao,


si, la tua immagine è esattamente come dovrebbe essere visualizzata la poligonale.....la mia invece è come in allegato.

Grazie dell'aiuto.
Andrea

cepe

  • Administrator
  • Hero Member
  • *****
  • Post: 549
    • Mostra profilo
Re:Segmento non corretto nel profilo
« Risposta #3 il: Febbraio 03, 2022, 12:15:44 pm »
Giuro che non so cosa possa essere...
Le uniche idee che mi vengono in mente sono legate alle impostazioni dei decimali nel sistema. Se non sono standard per la lingua impostata rimetti quelle standard e controlla se cosi va.

AndreaMara

  • Newbie
  • *
  • Post: 6
    • Mostra profilo
Re:Segmento non corretto nel profilo
« Risposta #4 il: Febbraio 03, 2022, 02:27:32 pm »
mmmmm.....in effetti sul file del ramo che ho allegato il profilo risulta corretto. Se invece lo visualzzo nel file del rilievo completo invece che esportando il singolo ramo mi da l'errore.


Ti allego il file completo e grazie ancora.
Andrea
« Ultima modifica: Febbraio 03, 2022, 02:29:49 pm da AndreaMara »

cepe

  • Administrator
  • Hero Member
  • *****
  • Post: 549
    • Mostra profilo
Re:Segmento non corretto nel profilo
« Risposta #5 il: Febbraio 03, 2022, 03:20:03 pm »
Hai un anello!
Con gli anelli la questione si complica. In pianta nessun problema in quanto mera proiezione dall'alto.
In sezione la cosa diventa più complicata in quanto cSurvey mostra solo la sezione estesa.
Essendoci, in caso di un anello, due vie diverse per raggiungere in certo numero di capisaldi, il programma segue le due strade e spezza la poligonale nel primo punto che trova già calcolato.
Il risultato può essere erratico quindi puoi/devi controllare dove avverrà la traslazione (che ci sarà sempre...salvo il caso teorico di due tratte esattamente lunghe uguali).
Puoi farlo in modo semplice con le "esclusioni".
Vai al caposaldo da cui inizia una delle due diramazione in cui l'anello si spezza (nel tuo caso 626 e 92): ad esempio 92.
Nelle proprietà dal caposaldo 92 vai nelle esclusioni e spunta di NON andare dal caposaldo 92 al caposaldo 178. Facendolo il programma non seguirà più quella via ed il ramo giallo apparirà tutto assieme fino proprio al caposaldo 92 che troverai 2 volte con relativa traslazione.
Ovviamente puoi fare uguale con l'altro caposaldo (626) se ritieni più leggibile la sezione spezzata nell'altro modo (non mi addentro su quale sia il modo migliore ne se vi siano standard).
Esiste poi un altro modo più complesso che è impostare per il ramo che rappresenta, di fatto, il percorso alternativo (giallo) una sotto-origine.