Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - cepe

Pagine: [1] 2 3 ... 33
1
How to / Re:import da excel con dati subacquei
« il: Dicembre 06, 2021, 08:49:12 am »
Si, infatti suggerivo di usare inclinazione comunque (anche se i tuoi dati sono di profondità).
Poi cambi dopo, a dati importati, la sessione indicando che quel dato non è un inclinazione ma una profondità.

2
Bug / Re:Two bugs
« il: Dicembre 05, 2021, 08:24:56 pm »
Before pasting the above code you have to unbox the formula (press the button with the box...).
Or paste only:
Codice: [Seleziona]
if currentsegment.to like "*SS*" then
        currentsegment.splay=true
        currentsegment.to=currentsegment.from & "(" & survey.segments.indexof(currentsegment) & ")"
    end if
    CurrentSegment.Save

3
How to / Re:import da excel con dati subacquei
« il: Dicembre 05, 2021, 08:21:57 pm »
L'import, in effetti, considera i dati solo 'classici' (distanza, azimut e inclinazione) però se tu importi i dati come li hai poi, una volta importati, li vai ad associare ad una sessione che abbia profondità e non inclinazione dovrebbe funzionare. In teoria non ricordo 'filtri' o altri limiti, in import, sui valori dell'inclinazione quindi dovrebbe importarti anche inclinazioni con valori <-90.
Considera che:
- la profondità deve essere negativa
- non ho mai avuto feedback riguardo alle sessioni con dati 'subacquei' quindi se trovi cose che non tornano non farti scrupolo di segnalarle.

4
How to / Re:Spessore bordi
« il: Novembre 30, 2021, 03:22:58 pm »
Se hai urgenza puoi aggirare il bug usando le regole per scala. Ne crei una per 1:5 ed imposti li lo spessore custom. Da me cosi funziona.
Nel codice al volo invece non riesco a capire dove abbia 'smesso' di caricare le impostazioni e mi serve tempo per indagare.

5
How to / Re:Spessore bordi
« il: Novembre 30, 2021, 03:13:56 pm »
Hai ragione...provato ora. Va solo la scala base ma le altre (direi tutte) non sembrano reagire.

6
How to / Re:Differenza anteprima di stampa
« il: Novembre 30, 2021, 03:11:10 pm »
Si...gli oggetti in stampa sono obsoleti e appaiono usabili solo nei rilievi 'vecchi' mentre in quelli creati exnovo non sono, di default, visibili.
Il motivo è che la personalizzabilità di questi oggetti è estramemente limitata. Sono tutti sostituibili con gli equivalenti oggetti che trovi nel livello simboli (con sfondo grigio) e sono oggetti 'speciali' perché non concorrono a centrarsi con il disegno (affinità=extra...la trovi nelle proprietà di ogni oggetti grafico).
Se comunque li vuoi usare lo stesso se vai in proprietà->disegno c'è una spunta di cui ora non ricordo il nome esatto che permette di attivare gli oggetti legacy.

7
How to / Re:Spessore bordi
« il: Novembre 30, 2021, 03:08:27 pm »
Si...è la voce linee marcate

8
Bug / Re:Two bugs
« il: Novembre 29, 2021, 08:45:37 am »
Do the actions I wrote in the last post.
Multiple selection on shots is allowed but not multiple changes. You have to use, for now, replicate data in right click (or in survey menu).

9
Bug / Re:Two bugs
« il: Novembre 28, 2021, 03:48:41 pm »
I can add an option in compass import to manage shot with SS in to station as splay.
At now you can apply a script to the survey fixing this.
Select all shots, right click on shot's grid and choose replicate data.
Check Apply formula ad edit formula (a script).
Unbox the formula and copy the code below:
Codice: [Seleziona]
public sub ReplicateFormula(CurrentSegment as object)
if currentsegment.to like "*SS*" then
        currentsegment.splay=true
        currentsegment.to=currentsegment.from & "(" & survey.segments.indexof(currentsegment) & ")"
    end if
    CurrentSegment.Save
end sub
Close formula and confirm data replication.
Refresh the grid (cause script don't do this).
Splay using this method remain showed ad normal shot but the program recognize it.

10
Bug / Re:Two bugs
« il: Novembre 25, 2021, 08:24:11 am »
About Compass import I will do some check with TopoDroid.

11
Bug / Re:Two bugs
« il: Novembre 25, 2021, 08:22:26 am »
The first problem will be fixed in the next version (2...).
For now you can delete the registry value storing the workspace settings manually:
Citazione
[HKEY_CURRENT_USER\SOFTWARE\Cepelabs\cSurvey]
"user.dockstate"
or executing .reg file below (that will work even for the next version).

12
Bug / Re:CSurvey does not load - puts out an error
« il: Novembre 24, 2021, 09:30:05 pm »
Glad to read this and,  yes, cSurvey has a lack of documentation (even italian's PDFmanual is old) due to the limited time I have available in spare time.
You can try translating the pdf (https://www.csurvey.it/download/csurvey.pdf)...is better then nothing.

13
Bug / Re:CSurvey does not load - puts out an error
« il: Novembre 24, 2021, 04:44:22 pm »
Try installing this patch:
https://www.microsoft.com/it-it/download/details.aspx?id=48145
cave_model.dll in the online compilation belong only to some few windows library: mscoree (framework...), MSVCP140.dll, VCRUNTIME140.dll and ucrtbase.dll.
The last three may by missing in your system and look at Microsoft download page cause there are 2 package (for 32 or 64 bit) so install both (or the one not working).

NOTE: ucrtbase.dll is a windows managed library so missing dlls could be only *140.dll

14
Bug / Re:Caposaldi spariti in Resurvey
« il: Novembre 24, 2021, 03:06:53 pm »
Allora indago...

15
Bug / Re:CSurvey does not load - puts out an error
« il: Novembre 24, 2021, 03:06:09 pm »
Sorry for the obvious question: in the cSurvey folder, where is not working, cave_model.dll exist?
Meanwhile I do some additional checks..

Pagine: [1] 2 3 ... 33